Nginx configuration with ISPConfig enviroment can't get vhost setup correctly

  • Hello everyone,

    I have been running into some problems with my Nginx configurations for EQDKP and have to say I am now drawing a blank on how to process from here.

    I managed to get EQDKP installed with all requirements green, but I just can't get url rewriting to work and just can't wrap my head around ISPConfig vhost files for nginx with the custom needs.

    So for some reason ISPConfig uses @php for processing PHP files with php-fpm and I don't know how I would need to edit the nginx config for EQDKP to get it working with my version.

    This is my main vhost file for EQDKP that is generated from ISPConfig. The problem here is in @php I don't know what kind of regular expression I need to create for it to work correctly

    This is the standard way to do it and on the first line location ~ \.php(/|$) this regular expression does things differently than just @php.

    My question is, does anyone have any ideas how to get this vhost file fixed? I can manually edit it from SSH and I am no stranger to Linux servers, so what needs to be done I can do it. I don't wanna change the engine from nginx to apache just for this cause I have liked nginx these past few years more.

    Currently generated errors with the running configuration is 500 Internal server error

    1. 2019/08/23 09:19:05 [error] 17209#17209: *93 rewrite or internal redirection cycle while internally redirecting to "/index.php//index.php//index.php//index.php//index.php//index.php//index.php/$
    2. 2019/08/23 09:24:05 [error] 17209#17209: *95 rewrite or internal redirection cycle while internally redirecting to "/index.php//index.php//index.php//index.php//index.php//index.php//index.php/$
    3. 2019/08/23 09:24:52 [error] 17209#17209: *96 rewrite or internal redirection cycle while internally redirecting to "/index.php//index.php//index.php//index.php//index.php//index.php//index.php/$

    I have tried to run the EQDKP sample nginx config, but it just confuses PHP-FPM more and I get all kinds of weird permissions errors etc... I am pretty sure I just need to get the regular expressions working and I need to find someone help me with Nginx itself not EQDKP necessarily :) So just to clarify, this problem isn't actually related to EQDKP itself, configuration problems with nginx.

    Thanks for anyone willing to guide me in right direction :thumbup:

  • I decided to bench Nginx for EQDKP and swapper Apache2 for engine. Working smooth now, got PHP-FPM 7.3 running with Apache2 etc.

  • Thanks for reporting back with your working setup.

    We ask for understanding, that we cannot help setting up the server environment itself for all possible constellations. If you encounter a problem with your webserver itself, we recommend asking your hosting company or at one of the many server administration forums on the internet.

    Please feel free to ask any question regarding EQdkp Plus on our forums. Most of our users are using Apache as well, so there is a chance, that one is able to help, if your question is related to Apache instead.

  • Yeah totally get it, its my own virtual machine and I know some basic things of Linux so I tried to work with it. But all those SEO and other htaccess rules are just too painful for me to start messing around and decided to try ask if someone has a quick fix for vhost configuration for nginx, but this time it's less of an hassle to use the platform the developers have designed the software to work on :D Hahaha, thanks for the great software none the less, this "bug" can be closed as "Wont fix/By design" status :)

    I got it now running on Debian 10 (Buster) with PHP 7.3-FPM with fastcgi proxy running on own user account on linux and "hardened" so if it gets owned, my linux won't. Seems to be working nicely, got all the cache working nice and pages load fast. Like I said before, the only problem here was me not being skilled enough to swap all the htaccess rules over to nginx on ISPConfig (It uses some weird aliases for things) and this time it was just easier to setup a small vm box with apache2 ;)