TS3-Modul mal wieder...

  • Hallo allerseits,


    ich habe das Problem, welches etliche hier schon hatten: ich schaffe es nicht, das TS3-Modul sauber einzurichten. Zu wissen sei an dieser Stelle:

    EQDKPlus läuft auf einem self-hosted Server.

    TS3 läuft auf dem gleichen Server

    Auf dem gleichen Server läuft auch das TeamSpeak Interface - dieses hat keine Probleme bei der Verbindung.

    Whitelisting in der entsprechenden txt für TS3 ist selbstverständlich ebenfalls hinterlegt.


    Fehlermeldung: Can not connect to the server (using SSH with Credentials)

    Im Log bei Debug 3 steht:

    Code
    1. fsockopen(): unable to connect to 148.251.21.17:10022 (Verbindungsaufbau abgelehnt)
    2. fclose() expects parameter 1 to be resource, null given


    (Was mich schon insofern wundert, als dass Teamspeak Interface keine Probleme hat).

    Ich hab mich dann aber über Port 10022 gewundert - standard für SSH ist ja eigentlich 22.

    Habe den Port auf 22 geändert.

    Nun bekomme ich von fsockopen keine Fehlermeldung mehr. Aber die

    Code
    1. fclose() expects parameter 1 to be resource, null given

    Meldung bleibt bestehen.

    Und es funktioniert auch weiterhin nicht ;)


    Die anderen Ports (9987 und 10011) sind korrekt - auch nochmal im TS-interface überprüft.


    Was mach ich denn zum Kuckuck immer noch falsch?

    Danke für eure Hilfe.


    Grüsse,

    KlyX

  • Ts3 unterstützt ssh in einer zukünftigen version. Wir haben deswegen die Unterstützung bereits eingebaut. Die ssh version wird über den genannten Port 10022 laufen. Verwende also lediglich die telnet sachen, wenn dein ts server mit ssh noch nichts anfangen kann.


    Außerdem sollte es passen, wenn du localhost bzw. 127.0.0.1 als ip einträgt, wenn alles auf dem gleichen server läuft.

    Viele Grüße,
    GodMod


    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken: | You want to thank me:

    amazon_wishlist.jpg paypal_logo.jpg

    • Dein Interface nutzt vermutlich den alten (unverschlüsselten) Weg über Telnet

    Die Query via SSH hat so gar nichts mit deinem sonstigen SSH-basierten Zugriff auf deinen Server zu tun. Du solltest definitiv nicht versuchen den SSH-Port deines TeamSpeak Servers auf Port 22 zu legen. Für weitere Informationen dazu muss ich dich allerdings zu Google verweisen, welches dir sicher einige Foren zum Thema Serveradministration vorschlagen kann.

  • 127.0.0.1 habe ich durchaus schon probiert. Hat zu nichts geführt ;)

    SSH dürfte wirklich kein Problem sein - ich meine, alle meine Administrationsverbindungen laufen über SSH bzw. SFTP. Deshalb wundert mich das.

    Bei Telnet meckert er jetzt übrigens über fehlenden Session Key. Was ist das denn nun schon wieder? :D


    Wenn ich Das SSH-Portfeld sowie serveradmin und pw leer lasse und nur Telnet drin lasse kommt dieser Fehler.

    Ich hätte noch den Token - aber kein passendes Feld dafür. Nach dem Fehler werden übrigens auch die Settings wieder zurückgestellt, wie ich sie ursprünglich eingetragen hatte.

  • Okay, hat sich erledigt - scheint als ob meine Session ausgelaufen war - warum auch immer ;)

    jetzt sind auch noch die Berechtigungen sauber gesetzt und es geht. Danke :)

  • Wie ich auf deine Seite sehen kann, scheinst du es ja hinbekommen zu haben.

    Viele Grüße,
    GodMod


    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken: | You want to thank me:

    amazon_wishlist.jpg paypal_logo.jpg