[Plugin Installieren] Es ist ein Fehler aufgetreten: Error 500

  • Es ist ein Fehler aufgetreten: Error 500


    Diese Fehlermeldung kommt wenn ich Plugins/Styles/Spiele installieren möcht


  • Fehler 500 ist ein interner Server-Fehler. Dein Log-Auszug enthält aber keine Beschreibung dieses Fehlers, von demher kann man zur Ursache nichts sagen.

    Du kannst Plugins aus unserem Download-Bereich manuell herunterladen, und dann entweder über die Erweiterungsverwaltung hochladen, oder aber wenn das nicht geht, einfach manuell auf deinen Webspace schieben. https://eqdkp-plus.eu/wiki/Erweiterungen_installieren


    Meine Vermutung: dein Server blockiert, weil CHMOD 0777 gesetzt wird. Deswegen kannst du über define('CHMOD', 0755); in der config.php ein anderes CHMOD setzen.

    Viele Grüße,
    GodMod


    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken: | You want to thank me:

    amazon_wishlist.jpg paypal_logo.jpg

  • Fehler 500 ist ein interner Server-Fehler. Dein Log-Auszug enthält aber keine Beschreibung dieses Fehlers, von demher kann man zur Ursache nichts sagen.

    Du kannst Plugins aus unserem Download-Bereich manuell herunterladen, und dann entweder über die Erweiterungsverwaltung hochladen, oder aber wenn das nicht geht, einfach manuell auf deinen Webspace schieben. https://eqdkp-plus.eu/wiki/Erweiterungen_installieren


    Meine Vermutung: dein Server blockiert, weil CHMOD 0777 gesetzt wird. Deswegen kannst du über define('CHMOD', 0755); in der config.php ein anderes CHMOD setzen.


    Puh..

    Code
    1. define("CHMOD", 0744);


    scheint mir von den Rechten passend zu sein. Hast du vielleicht eine Idee woran es sonst noch liegen könnte? Ist auch meine zweite Eqdkp Installation. Bei der andren hatte ich keine Probleme.


    lg


    edit:

    scheint auch bei der etwas älteren(2.2.18)

    Version vorzukommen.

  • Wie gesagt, ohne genaue Fehlermeldung aus dem Server-Log kann ich den Fehler nicht benennen und nicht weiterhelfen. Wende dich ansonsten auch gerne mal an deinen Hoster.

    Viele Grüße,
    GodMod


    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken: | You want to thank me:

    amazon_wishlist.jpg paypal_logo.jpg

  • Wie gesagt, ohne genaue Fehlermeldung aus dem Server-Log kann ich den Fehler nicht benennen und nicht weiterhelfen. Wende dich ansonsten auch gerne mal an deinen Hoster.

    Root Server und so... wenn ich was kaputt mach bin ich selber schuld :/

  • Dann solltest du nochmal das Apache-Errorlog durchkucken nach einer Ursache für den 500er (Fatal error oder ähnliches).

    Viele Grüße,
    GodMod


    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken: | You want to thank me:

    amazon_wishlist.jpg paypal_logo.jpg

  • Dann solltest du nochmal das Apache-Errorlog durchkucken nach einer Ursache für den 500er (Fatal error oder ähnliches).

    nginx im übrigen. Aber ich finde nichts. Die Einstellungen für error logging stimmen alle. Bei dem Versuch eine Erweiterung zu installieren gibt es lediglich Warnungen.

    Code
    1. 2018/07/19 20:58:12 [error] 22534#22534: *2896 FastCGI sent in stderr: "PHP message: PHP Warning: Illegal string offset '#uc_coreupdate_available' in /var/www/eqdkp/libraries/jquery/jquery.class.php on line 1420


    DIe taucht bei meiner anderen Eqdkp Installation auf. Aber mehr ist nicht in den Logs zu finden. Trotzdem danke für deine Hilfe.

  • Puh..

    Problem anscheinend gelöst. Der Fehler war das nicht installierte "php7.2-zip" Paket. Ist mir aufgefallen, also ich gerade den neuen RC ausprobieren wollte und diser das Modul zwingend vorschreibt.

  • Dann sollte aber eben jenes fehlen irgendwo geloggt werden... Php müsste dann einen fatal error werfen, welcher in einem Log sichtbar wird.. Naja, jedenfalls schön dass du es gelöst hast.

    Viele Grüße,
    GodMod


    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken: | You want to thank me:

    amazon_wishlist.jpg paypal_logo.jpg

  • Dann sollte aber eben jenes fehlen irgendwo geloggt werden... Php müsste dann einen fatal error werfen, welcher in einem Log sichtbar wird.. Naja, jedenfalls schön dass du es gelöst hast.

    Dachte ich mir auch. Log level hab ich angeschaut - der hätte passen müssen. Aber egal.


    An dieser Stelle fällt mir noch ein kleiner Verbesserungsvorschlag ein. Da die Version 2.2 sich ohne aktives zip packet installieren lässt wäre ein passender Hinweis auf der Pluginseite Hilfreich.



    edit:

    Da ich sowas ja auch selber machen kann. Wie ist euer gewünschter Workflow? Einfach einen PR in Git oder erst im Bugtracker ein Featurewunsch Ticket aufmachen?

  • Naja, die Installation der plugins über die Verwaltung ist eine Komfortfunktion, es geht auch manuell. Deswegen ist zip keine harte Voraussetzung. Ich werde aber im Installer der 2.2 das mal härter abfragen.


    Du kannst direkt PRs senden, ob sie dann gemerged werden hängt davon ab, ob die Änderungen für alle sinnvoll sind.

    Viele Grüße,
    GodMod


    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken: | You want to thank me:

    amazon_wishlist.jpg paypal_logo.jpg